Blog Upgraded

Upgraded to WP 2.9 and also OpenID plugin.

Now all we need is foaf+ssl!

flattr this!

This entry was posted in Uncategorized. Bookmark the permalink.

One Response to Blog Upgraded

Comments are closed.